[BRLTTY] [PATCH] Use print function for Python 3 compatibility

Joanmarie Diggs jdiggs at igalia.com
Mon Nov 5 07:08:16 EST 2012

Hey all.

While the GNOME 3.6 release was a Python 3 drill, the GNOME 3.8 release
will be Python 3 for real as per the Release Team's announcement last
night. As a result, I'm now testing Orca with brltty and brlapi built
for Python 3 and will either tweak in Orca or submit patches here as

Attached is the first patch that needs to be done on your end. Without
it, I cannot build the Python 3 bindings. The print function is required
in Python 3. It was backported to Python 2.6 and later. So this patch is
compatible as long as people are not using an ancient version of Python
2. :)

On the Orca side, I have just committed a change to Orca master to use
Byte strings instead of the new, Python 3 default which is Unicode
strings. With any luck, that will make it unnecessary for whatever
Luke's hack had been.

I'm still testing and will keep y'all posted! :)

Thanks and take care.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: use-print-function.patch
Type: text/x-patch
Size: 3072 bytes
Desc: not available
URL: <http://mielke.cc/pipermail/brltty/attachments/20121105/64fe08e4/attachment.bin>

More information about the BRLTTY mailing list