[BRLTTY] Fedora core 7 & brltty 3.8

Jason White jasonw at ariel.its.unimelb.edu.au
Thu Jun 14 23:20:27 EDT 2007

On Thu, Jun 14, 2007 at 10:53:44PM -0400, Dave Mielke wrote:
> Please try an experiment for me. Go to "/sys/bus/usb/devices/b-d/", where b is
> the bus number and d is the device number. To find the one which corresponds to
> your device, check what's in the file "manufacturer". When you find the right
> one, go into the "power/" subdirectory". In there you should find a file named
> "autosuspend". If you cat it, it'll probably say the number 2. Try using echo
> to write 0 into it.
>    echo 0  >autosuspend
> With that change made, please see if you're then able to get your device to
> work. Remember that unplugging/replugging your device will undo the change.

I made this change and then ran BRLTTY, which worked after a few seconds.
Killing and restarting BRLTTY, with the change still in effect, also worked.

The following message appeared on the console and in syslog:

Jun 15 13:14:49 jpc kernel: usb 2-1: reset full speed USB device using
and address 2

More information about the BRLTTY mailing list